Author Topic: New Problem error 438  (Read 2226 times)

sweinkle

  • Member
  • **
  • Posts: 10
New Problem error 438
« on: December 04, 2011, 08:19:23 AM »
What is causing multiple instances of error 438 generated by modMenu when I run a clean, new install of Enterprise 4.0.7 in Access 2003? The immediate first problem is that the error crashes the installation wizard.

opengateadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 336
    • Microsoft Access
Re: New Problem error 438
« Reply #1 on: December 04, 2011, 02:09:07 PM »
This is usually caused when an Office or Access library file (DLL) isn't registered properly on the machine.  I would suggest starting by repairing your install:

http://www.opengatesw.net/ms-access-tutorials/Repairing-Office-Install.htm

If that doesn't work, please let us know!

sweinkle

  • Member
  • **
  • Posts: 10
Re: New Problem error 438 - problem continues
« Reply #2 on: December 05, 2011, 07:58:04 AM »
I ran 2003 recovery which reported that it completed Office recovery.
The 1st instance of the error is in frmSetupWizard in Sub sUpdateStep() where the program fails on the line: ctl.backcolor = ~. But if I rem these lines out, I get other common property failures in other modules.
I get the same errors if I open the program in 2007.

opengateadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 336
    • Microsoft Access
Re: New Problem error 438
« Reply #3 on: December 05, 2011, 06:14:44 PM »
This is a strange problem.  Would you be able to send a screenshot of your VB references to support@opengatesw.net?  To Do so:

1) Select CTRL+G in Access.
2) Select the blue stop sign (blue square) in the toolbar of the VB Editor.
3) Select "Tools>>References".  The window that pops up is what will help.

Thanks!

sweinkle

  • Member
  • **
  • Posts: 10
Re: New Problem error 438
« Reply #4 on: December 06, 2011, 07:33:32 AM »
Here's the references and a shot of the first instance of the error. I'm baffled because everything looks to be right. This is from a clean copy of the 4.0.7 database with zero editing. If I REM out the affected lines in this procedure, then the next procedure using standard properties reports the error.

File sent to support.
Thanks, Steve

opengateadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 336
    • Microsoft Access
Re: New Problem error 438
« Reply #5 on: December 06, 2011, 02:47:05 PM »
This is definitely a new one.  Thanks for your patience.  I launched the copy you sent on a machine with Access 2003 and couldn't replicate the error.  Do you have time tomorrow to do a quick online meeting?  Any time between 12 and 4PM EST works for me.

I tried replying to the email, and it bounced (probably a spam filter).

sweinkle

  • Member
  • **
  • Posts: 10
Re: New Problem error 438
« Reply #6 on: December 06, 2011, 05:03:10 PM »
I've been traveling in China this week - returning Thursday to Atlanta. Can  we do an online meeting FRIDAY at your convenience?

opengateadmin

  • Administrator
  • Sr. Member
  • *****
  • Posts: 336
    • Microsoft Access
Re: New Problem error 438
« Reply #7 on: December 09, 2011, 01:10:39 AM »
Absolutely, Friday it is.  I'll call the number on your email.